Install matplotlib on mac sierra

During matplotlib installation (for python3) some error may occured:
‘The following required packages can not be built:
* freetype
* png’

Thats why some additional steps may be required:

  1. install homebrew

  2. install pkg-config

    brew install pkg-config
    
  3. install freetype

    brew install freetype
    
  4. install matplotlib

    pip3 install matplotlib
    

Enjoy!